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1
Introduction
Dell OpenManage Connection for IBM Tivoli Netcool/OMNIbus provides event monitoring capabilities for Dell 
PowerEdge and PowerVault servers, Dell EqualLogic systems, and Dell Chassis Management Controller (CMC).

This guide provides information on the software prerequisites, requirements, and steps to manually install the Dell 
OpenManage Connection integration components on the Netcool/OMNIbus components.
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2
Prerequisites
Complete the following prerequisites.

Requirements For The Managing System
The following table lists the requirements for integrating the Dell OpenManage Connection on the systems where the 
Netcool/OMNIbus components are installed.
Table 1. IBM Netcool/OMNIbus Component Requirements

Component Requirement Purpose

Probes Configure the MTTrapd Simple 
Network Management Protocol 
(SNMP) probe and the Netcool/
OMNIbus Knowledge Library (NcKL).

To receive and process the SNMP 
traps sent by Dell devices.

ObjectServer Install and configure the confpack 
utility.

To import Dell integration automation 
triggers, tools, menus, and conversion 
classes.

Desktop Make sure that the SNMP 
communication between the desktop 
and Dell devices is established.

To retrieve the required information 
from Dell devices.

Web GUI Install and configure the OMNIbus 
web GUI and WAAPI.
Make sure that the SNMP 
communication channel between the 
web GUI server and the managed Dell 
systems is established.

To support Dell tools available for Dell 
OpenManage Connection.
To support Dell tools and menus.

Requirements For The Managed System
The following table lists the requirements of the systems that are managed by Dell OpenManage Connection.
Table 2. Managed System Requirements

Dell Devices Requirement

Dell Systems Running Windows • OMSA versions 6.5–7.1
• SNMP Service

Dell Systems Running Linux • OMSA versions 6.5–7.1
• SNMP Service

Dell Systems Running ESXi • ESXi version 4.0 U1 and later
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Dell Devices Requirement

• OMSA versions 6.5–7.1
• SNMP Service

Dell EqualLogic Storage Arrays • Firmware versions 5.0–6.0
• SNMP Service

Dell OOB Servers (iDRAC) • Firmware versions 1.0 and 1.23.23
• SNMP Service

Dell CMC • Firmware versions 4.11 and 4.2
• SNMP Service

NOTE: OOB and iDRAC are used interchageably in the document. iDRAC refers to 12G iDRAC7.

Dell OpenManage Connection For Netcool/OMNIbus File And 
Folder Details
The Dell OpenManage Connection for Netcool/OMNIbus is packaged as a zip file. This is applicable to both Windows 
and Linux. You can download this zip file from support.dell.com. When you extract the zip file, the following files are 
extracted:

• Dell_Server_Integration_v2_0.zip — contains the probe, object, desktop, and web GUI integration folders for 
supporting Dell servers.

• Dell_Server_iDRAC_Integration_v2_0.zip — contains the probe, object, desktop, and web GUI integration 
folders for supporting integrated Dell Remote Access Controller (iDRAC).

• Dell_EqualLogic_Integration_v2_0.zip — contains the probe, object, and web GUI integration folders for 
supporting Dell EqualLogic.

• Dell_CMC_Integration_v2_0.zip — contains the probe, object, desktop, and web GUI integration folders for 
supporting Dell Chassis Management Controller (CMC).

• Dell_Common_Tools_Integration_v2_0.zip — contains the object and web GUI integration folders for supporting 
Dell OpenManage Essentials.

• Dell_OMC_2_0_For_IBM_OMNIbus_IG.pdf — contains the procedure to install Dell OpenManage Connection 
for IBM Netcool/OMNIbus.

• Dell_OMC_2_0_ReadMe.txt — contains details of the new features, system requirements for installing Dell 
OpenManage Connection for IBM Netcool/OMNIbus, installation prerequisites and so on.

• license_en.txt— contains the license agreement for IBM Netcool/OMNIbus.

Deploy the contents of the zip files on the corresponding Netcool/OMNIbus components to monitor the supported Dell 
devices.

Integration Details For Netcool/OMNIbus Components

Extract the contents of the following zip files:

• Dell_Server_Integration_v2_0.zip
• Dell_EqualLogic_Integration_v2_0.zip
• Dell_Server_iDRAC_Integration_v2_0.zip
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• Dell_CMC_Integration_v2_0.zip

• Dell_Common_Tools_Integration_v2_0.zip

The following table lists the Netcool/OMNIbus components and the Integration folders for Dell OpenManage 
Connection. Deploy the integration files of Dell OpenManage Connection from the corresponding folder to the Netcool/
OMNIbus components folder.

Table 3. Netcool/OMNIbus Components

Component Integration folders

probe_integration Contains the rules and lookup table files for servers, EqualLogic storage 
arrays, OOB servers, and CMC.

NOTE: Probe integration is not applicable to Dell Common Tools.

objectserver_integration Contains the exported Dell integration automation triggers, tools, 
menus, and conversion classes.

desktop_integration Contains utilities or tools that you require for:

• Configuring the SNMP community name string
• Launching the Server Administrator console from the Netcool/

OMNIbus desktop
• Launching the iDRAC console from Netcool/OMNIbus desktop
• Launching the CMC console from Netcool/OMNIbus desktop

NOTE: This integration is not available in 
Dell_EqualLogic_Integration_v2_0.zip and 
Dell_Common_Tools_Integration_v2_0.zip.

webgui_integration Contains the Dell integration tools, menus, and applications that you 
require for:

• Configuring the SNMP community name string
• Launching the Server Administrator console from the Netcool/

OMNIbus web GUI
• Launching the Server Administrator web server console from 

the Netcool/OMNIbus web GUI
• Launching the EqualLogic Group Manager console from 

Netcool/OMNIbus web GUI
• Launching the iDRAC console from Netcool/OMNIbus web GUI
• Launching the CMC console from Netcool/OMNIbus web GUI
• Launching the OpenManage Essentials (OME) console from 

Netcool/OMNIbus web GUI
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3
Installing Dell OpenManage Connection For 
Netcool/OMNIbus
To install Dell OpenManage Connection for Netcool/OMNIbus you must extract the component specific files on the 
systems where you have installed the Netcool/OMNIbus components and deploy them. For more information on 
extracting component-specific files, see Integration Details For Netcool/OMNIbus Components.

Before you begin deploying the files:

1. Download the Dell_OpenManage_Connection_for_OMNIbus_v2_0.zip file from support.dell.com and extract the 
contents to a folder.
The following files are extracted:

– Dell_Server_Integration_v2_0.zip
– Dell_EqualLogic_Integration_v2_0.zip
– Dell_Server_iDRAC_Integration_v2_0.zip
– Dell_CMC_Integration_v2_0.zip
– Dell_Common_Tools_Integration_v2_0.zip
– Dell_OMC_2_0_For_IBM_OMNIbus_IG.pdf
– Dell_OMC_2_0_ReadMe.txt
– license_en.txt

NOTE: You can extract the contents of the zip files as per your monitoring requirement.

2. Extract the contents of Dell_Server_Integration_v2_0.zip to a separate folder. This includes the following folders:

– desktop_integration
– objectserver_integration
– probe_integration
– webgui_integration

3. Extract the contents of Dell_EqualLogic_Integration_v2_0.zip to a separate folder. This includes the following 
folders:

– objectserver_integration
– probe_integration
– webgui_integration

4. Extract the contents of Dell_Server_iDRAC_Integration_v2_0.zip to a separate folder. This includes the following 
folders:

– desktop_integration
– objectserver_integration
– probe_integration
– webgui_integration

5. Extract the contents of Dell_CMC_Integration_v2_0.zip to a separate folder. This includes the following folders:

– desktop_integration
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– objectserver_integration

– probe_integration

– webgui_integration

6. Extract the contents of Dell_Common_Tools_Integration_v2_0.zip to a separate folder. This includes the following 
folders:

– objectserver_integration

– webgui_integration

7. Log in as Netcool administrator on any system where you have installed any of the Netcool/OMNIbus components.

Installing Probe Integration
The probe integration folders located in the Dell_Server_Integration_v2_0.zip, Dell_EqualLogic_Integration_v2.0 zip, 
Dell_Server_iDRAC_Integration_v2.0.zip, and Dell_CMC_Integration_v2_0.zip files, contain rules, lookup, and version 
files for the respective integrations.

To deploy the integration of server, EqualLogic, iDRAC, and CMC traps:

1. Copy the dell folder under probe_integration and place it under the %NC_RULES_HOME%\include-snmptrap folder 
on the system where you have installed the Probe component.

NOTE: On systems running Linux, use the $NC_RULES_HOME/include-snmptrap folder.

2. Open the NcKL master probe rules file under the %NC_RULES_HOME% folder and perform the following steps:

a. Append the following command in the include rules section:
include "$NC_RULES_HOME/include-snmptrap/dell/dell.master.include.rules"

b. Append the following command in the include lookup table section:
include "$NC_RULES_HOME/include-snmptrap/dell/dell.master.include.lookup"

3. Ensure that the copied dell folder and the files under it have permissions for the probe rules in accordance with the 
IBM guidelines. For more information, see IBM Netcool/OMNIbus documentation.

4. Perform the followings steps:
Server traps

a. Uncomment the dell-StorageManagement-MIB.include.snmptrap.lookup file include 
statement in the dell.master.include.lookup file.

b. Uncomment the dell-MIB-Dell-10892.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

c. Uncomment the dell-StorageManagement-MIB.include.snmptrap.rules file include 
statement in the dell.master.include.rules file.

d. Uncomment the dell-MIB-Dell-10892.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

EqualLogic traps

a. Uncomment the equalLogic-EQLMEMBER-MIB.include.snmptrap.lookup file include 
statement in the dell.master.include.lookup file.

b. Uncomment the equalLogic-EQLDISK-MIB.include.snmptrap.lookup file include statement in 
the dell.master.include.lookup file.

c. Uncomment the equalLogic-SCSI-MIB.include.snmptrap.lookup file include statement in 
the dell.master.include.lookup file.

d. Uncomment the equalLogic-EQLMEMBER-MIB.include.snmptrap.rules file include statement 
in the dell.master.include.rules file.
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e. Uncomment the equalLogic-EQLDISK-MIB.include.snmptrap.rules file include statement in 
the dell.master.include.rules file.

f. Uncomment the equalLogic-SCSI-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

g. Uncomment the equalLogic-ISCSI-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

OOB server traps

a. Uncomment the dell-IDRAC-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

b. Uncomment the dell-IDRAC-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

CMC traps

a. Uncomment the dell-RAC-MIB.include.snmptrap.lookup file include statement in the 
dell.master.include.lookup file.

b. Uncomment the dell-RAC-MIB.include.snmptrap.rules file include statement in the 
dell.master.include.rules file.

5. Restart the OMNIbus MTTrapd SNMP probe service (NCOMTTRAPDProbe) or process (nco_p_mttrapd).

Installing ObjectServer Integration
The objectserver_integration folder contains the dell_server_confpack_v_2_0.jar file for servers, 
dell_equallogic_confpack_v_2_0.jar file for EqualLogic storage arrays, dell_serveridrac_confpack_v_2_0.jar file for 
iDRAC server, dell_cmc_confpack_v_2_0.jar file for CMC, and dell_commontools_confpack_v_2_0.jar file for Common 
Tools such as Dell OpenManage Essentials. These jar files contain the exported Dell integration automation triggers, 
tools, menus, and conversion classes.

The objectserver_integration folder also contains the version file:

• dellserver_int_objectserver.ver — for server integration

• delleql_int_objectserver.ver — for EqualLogic integration

• dellserveridrac_int_objectserver.ver — for iDRAC server integration

• dellcmc_int_objectserver.ver — for CMC integration

• dellcommontools_int_objectserver.ver — for Common Tools integration

To deploy the Dell integration components on the system that hosts the ObjectServer:

1. Run the following command with the required security credentials to access the OMNIbus ObjectServer:

a. On systems running Windows

* Servers
%OMNIHOME%\bin\nco_confpack.bat -import -server <ObjectServer> -
user <username> -password <password> -package <copiedfolder>
\dell_server_confpack_v_2_0.jar

* EqualLogic storage arrays
%OMNIHOME%\bin\nco_confpack.bat -import -server <ObjectServer> -
user <username> -password <password> -package <copied folder>
\dell_equallogic_confpack_v_2_0.jar
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* OOB servers
%OMNIHOME%\bin\nco_confpack.bat -import –server <ObjectServer> -
user <username> -password <password> -package <copied folder>
\dell_serveridrac_confpack_v_2_0.jar

* CMC
%OMNIHOME%\bin\nco_confpack.bat -import –server <ObjectServer> -
user <username> -password <password> -package <copied folder>
\dell_cmc_confpack_v_2_0.jar

* Common Tools
%OMNIHOME%\bin\nco_confpack.bat -import –server <ObjectServer> -
user <username> -password <password> -package <copied folder>
\dell_commontools_confpack_v_2_0.jar

b. On systems running Linux

* Servers
$OMNIHOME/bin/nco_confpack -import -server <ObjectServer> -user 
<username> -password <password> -package <copied folder>/
dell_server_confpack_v_2_0.jar

* EqualLogic storage arrays
$OMNIHOME/bin/nco_confpack -import -server <ObjectServer> -user 
<username> -password <password> -package <copied folder>/
dell_equallogic_confpack_v_2_0.jar

* OOB servers
$OMNIHOME/bin/nco_confpack -import -server <ObjectServer> -user 
<username> -password <password> -package <copied folder>/
dell_serveridrac_confpack_v_2_0.jar

* CMC
$OMNIHOME/bin/nco_confpack -import -server <ObjectServer> -user 
<username> -password <password> -package <copied folder>/
dell_cmc_confpack_v_2_0.jar

* Common Tools
$OMNIHOME/bin/nco_confpack -import -server <ObjectServer> -user 
<username> -password <password> -package <copied folder>/
dell_commontools_confpack_v_2_0.jar

NOTE: By default, ObjectServer is NCOMS.

NOTE: If the nco_confpack command displays the Unsupported Operating System error, see 
ibm.com/support/docview.wss?crawler=1&uid=swg1IV28036 , for resolution.

2. In the Event List on the desktop, click File → Resync → All. This action synchronizes the newly added menu items 
for the Dell tools and conversion classes that are updated from the jar files.

NOTE: Resync can be performed only for ObjectServer integration.

3. In the %OMNIHOME% directory on the system where the ObjectServer is installed, copy the file:

– dellserver_int_objectserver.ver — for server integration

– delleql_int_objectserver.ver — for EqualLogic integration

– dellserveridrac_int_objectserver.ver — for OOB server integration

– dellcmc_int_objectserver.ver — for CMC integration

– dellcommontools_int_objectserver.ver — for Common Tools integration

NOTE: On systems running Linux, use the $OMNIHOME directory.

4. Restart the web GUI.
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Configuring Dell Server Administrator Web Server Console On The ObjectServer

The Dell Server Administrator Web Server Console uses the configured URL to launch the console in the default 
browser.

To configure the Web Server Console URL for systems running Windows and Linux:

1. Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.
2. In the Configuration window, select Menu → Tools.
3. On systems running Windows, double-click Launch Dell Server Administrator Web Server Console (Windows) on 

the right pane to launch the Tool Details window.
On systems running Linux, double-click Launch Dell Server Administrator Web Server Console on the right pane to 
launch the Tool Details window.

4. Click the executable tab and edit the following command:
https://<Server Administrator Web Server Host/IP>:<Server Administrator Web 
Server PORT>/omalogin.html?managedws=false&mnip=@Node

You must provide the IP address and the port of the Server Administrator Web Server. For example: https://
11.95.145.156:1311/omalogin.html?managedws=false&mnip=@Node. For more information, see the Server 
Administrator documentation.

Configuring OpenManage Essentials Console On The ObjectServer

The OpenManage Essentials console uses the configured URL to launch the console in the default browser.

To configure the OpenManage Essentials console URL for systems running Windows and Linux:

1. Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.
2. In the Configuration window, select Menu → Tools.
3. Double-click Launch Dell OpenManage Essentials Console (Windows) on the right pane to launch the Tool Details 

window.
4. Click the executable tab and edit the following command:

https://<OpenManage Essentials Host/IP>:<OpenManage Essentials PORT>

You must provide the IP address and the port of the OpenManage Essentials. For example: https://
11.95.145.156:2607/. For more information, see the OpenManage Essentials User's Guide at dell.com/support/
manuals.

Installing Desktop Integration
The desktop_integration folder for Dell devices contains the following files:

• dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar — configures the SNMP community name string.
• dell_OMNIbus_Connection_SNMP_Helper_v_2_0.jar — launches consoles of the supported Dell devices.
• snmp4j-2.1.0.jar — SNMP Helper uses this file to establish the SNMP communication with Dell devices.
• dell_config.properties — contains the encrypted SNMP community string.
• dellserver_int_desktop.ver — version file for Server Administrator desktop integration.
• dellserveridrac_int_desktop.ver — version file for iDRAC desktop integration.
• dellcmc_int_desktop.ver — version file for CMC desktop integration.

To deploy the Dell integration components on the system that hosts the desktop client:
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1. Copy the dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar, 
dell_OMNIbus_Connection_SNMP_Helper_v_2_0.jar, snmp4j-2.1.0.jar, and dell_config.properties files in the 
%OMNIHOME% directory on the system where you have installed the desktop client.

NOTE: On systems running Linux, use the $OMNIHOME directory.

2. In the %OMNIHOME% directory on the system where you have installed the desktop client, copy the files:

– dellserver_int_desktop.ver — for server integration
– dellserveridrac_int_desktop.ver — for iDRAC integration
– dellcmc_int_desktop.ver — for CMC integration

3. Configure the SNMP Community using the Dell SNMP Configurator utility. For more information, see SNMP 
Configurator Utility.

Installing Web GUI Integration
The import sub folder within the webgui_integration folder contains the following files and sub folders:

• config — Contains the cgi-bin folder with the following files:

– omsalauncher_linux.cgi
– omsalauncher_nt.cgi
– idraclauncher_linux.cgi
– idraclauncher_nt.cgi
– cmclauncher_linux.cgi
– cmclauncher_nt.cgi

• dell_config.properties — Contains the encrypted SNMP community string.
• dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar — Configures the SNMP community name string.
• dell_OMNIbus_Connection_SNMP_Helper_v_2_0.jar — Launches the OpenManage Server Administrator 

(OMSA), Integrated Dell Remote Access Controller (iDRAC), and Dell CMC URLs.
• dellserver_int_webgui.ver — Version file for Server Administrator web GUI integration.
• dellcmc_int_webgui.ver — Version file for Dell CMC web GUI integration.
• dellserveridrac_int_webgui.ver — Version file for iDRAC web GUI integration
• dellcommontools_int_webgui.ver — Version file for Dell OME web GUI integration
• export.xml — Exports menus and tools and for registering cgi scripts.
• snmp4j-2.1.0.jar — SNMP Helper uses this file to establish the SNMP Communication with Dell devices.

To deploy the Dell integration components on the system that hosts the web GUI:

1. Copy the dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar, 
dell_OMNIbus_Connection_SNMP_Helper_v_2_0.jar, snmp4j-2.1.0.jar , and dell_config.properties files in the <Web 
GUI home directory> on the system where you have installed the web GUI component.

2. Configure the SNMP Community using the Dell SNMP Configurator utility. For more information, see SNMP 
Configurator Utility.

3. On the system where the web GUI component is installed, in the <Web GUI home directory>, copy the files:

– dellserver_int_webgui.ver — server integration
– dellserveridrac_int_webgui.ver — Dell OOB server
– dellcmc_int_webgui.ver — Dell CMC Integration
– dellcommontools_int_webgui.ver — Dell Common Tools Integration

4. Navigate to the import folder in the location where you have extracted webgui_integration folder and run the 
following command for each integration:
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On systems running Windows —
<Web GUI home directory>\waapi\bin\runwaapi -host <hostname> -user <Web GUI 
username> -password <Web GUI password> -file export.xml

On systems running Linux —
<Web GUI home directory>/waapi/bin/runwaapi -host <hostname> -user <Web GUI 
username> -password <Web GUI password> -file export.xml

NOTE: The first two steps are applicable only to servers and iDRAC.

Dell SNMP Configurator Utility

Using the Dell SNMP Configurator utility, you can set the SNMP community string for desktop and web GUI.

NOTE: Once the community string is configured using the Dell SNMP Configurator utility, the same community 
string is used for OMSA, CMC, and iDRAC console launches.

Related Links:

• Using The SNMP Configurator Utility For Desktop
• Using The SNMP Configurator Utility For Web GUI

Using The SNMP Configurator Utility For Desktop

To use the SNMP Configurator Utility to set the SNMP community string:

1. Navigate to the OMNIHOME directory on the system where the Desktop component is installed.
2. Run the following command for Desktop:

a) On systems running Windows —
%NCHOME%\platform\<specificplatform>\jre_1.6.7\jre\bin\java -
Ddell.config.path=desktop -classpath %NCHOME%\omnibus
\dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar;%NCHOME%\omnibus
\snmp4j-2.1.0.jar com.dell.openmanage.connections.SnmpConfigurator

b) On systems running Linux —
$NCHOME/platform/<specificplatform>/jre_1.6.7/jre/bin/java -
Ddell.config.path=desktop -classpath $NCHOME/omnibus/
dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar:$NCHOME/omnibus/
snmp4j-2.1.0.jar com.dell.openmanage.connections.SnmpConfigurator

Using The SNMP Configurator Utility For Web GUI

To use the SNMP Configurator utility to set the SNMP community string:

1. Navigate to the web GUI Installation directory on the system where the web GUI component is installed.
2. Run the following command for web GUI:

a) On systems running Windows —
<Tivoli Integrated Portal home directory>\java\jre\bin\java -
Ddell.config.path=webgui -classpath %NCHOME%\omnibus_webgui
\dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar;%NCHOME%
\omnibus_webgui\snmp4j-2.1.0.jar 
com.dell.openmanage.connections.SnmpConfigurator

b) On systems running Linux —
<Tivoli Integrated Portal home directory>/java/jre/bin/java -
Ddell.config.path=webgui -classpath $NCHOME/omnibus_webgui/
dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar:$NCHOME/
omnibus_webgui/snmp4j-2.1.0.jar 
com.dell.openmanage.connections.SnmpConfigurator
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Configuring Dell Tools Menu

When you import multiple Dell web GUI integrations, the associations between specific Dell tools and the Dell Tools 
menu are lost.

To configure the menu for Dell tools:

1. Log in to the Web GUI.

2. Click Administration → Event Management Tools.

3. Select Menu Configuration.

4. On the Available menus, select DellTools, and then click Modify.

5. On the Available items menu, select tool from the drop-down menu.

6. Select the required tool to associate with the Dell Tools Menu, and then move the tool to Current items.

7. Select the tool from the Current items, and then click the rename icon.
The Rename Menu Item window is displayed.

Table 4. Label Names For Dell Tools

Tool Name Label Name

LaunchDellChassisManagementControllerConsole Launch Dell Chassis Management Controller Console

LaunchDellEqualLogicGroupManagerConsole Launch Dell EqualLogic Group Manager Console

LaunchDelliDRACConsole Launch iDRAC Console

LaunchDellServerAdministratorConsole Launch Dell Server Administrator Console

LaunchDellServerAdministratorWebServerConsole Launch Dell Server Administrator WebServer Console

LaunchDellOpenManageEssentialsConsole Launch Dell OpenManage Essentials Console

8. Provide a new name in the Label field.

9. Click Save, and then close the window.

10. Save and close the Menu Editor window.

11. Follow the steps described in the section, Updating The Dell Tools Menu On The Web GUI Server.

Updating The Dell Tools Menu On The Web GUI Server

To update the Dell Tools menu on the Alerts menu of the web GUI component:

1. Perform the following steps to edit the Alert menu:
a) Click Administration → Event Management Tools.
b) Navigate to Menu Configuration.
c) Select Alerts from the Available menus on the right pane.
d) Click Modify.
e) Select menu from the Available items drop-down list.
f) Add Dell Tools to the Current items.
g) Click Save.

2. Navigate to Administration → Availability → Events → Active Event List (AEL) and refresh the list to synchronize 
the newly added menu items.

3. Right-click on a Dell device alert and make sure that the respective Dell devices are available.
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Configuring Dell Server Administrator Web Server Console On The Web GUI

To configure the Launch Dell Server Administrator web server console:

1. Log in to the web GUI.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Select LaunchDellServerAdministratorWebServerConsole on the right pane to launch the Tool Configuration 
window.

4. Edit the following URL:
https://<Server Administrator Web Server Host/IP>:<Server Administrator Web 
Server PORT>/omalogin.html?managedws=false&mnip=@Node

You must provide the IP address and the port of the Server Administrator Web Server. For example:https://
11.95.145.156:1311/omalogin.html?managedws=false&mnip=@Node. For more information, see the Server 
Administrator documentation.

Configuring Dell OpenManage Essentials Console On The Web GUI

To configure the Launch Dell OpenManage Essentials console:

1. Log in to the web GUI.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Select LaunchDellOpenManageEssentialsConsole on the right pane to launch the Tool Configuration window.

4. Edit the following URL:
https://<OpenManage Essentials Host/IP>:<OpenManage Essentials PORT>

You must provide the IP address and the port of the OME Web Server. For example:https://11.95.145.156:2607/. For 
more information, see the OpenManage Essentials User's Guide at dell.com/support/manuals.

Configuring Dell Server Administrator Launch Tool On The Web GUI Server For Systems 
Running Linux 

To configure the Launch Dell Server Administrator tool on systems running Linux:

1. Log in to the Web GUI running on a Linux system.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Double-click LaunchDellServerAdministratorConsole.

4. Modify the name of the CGI Script in the URL section to omsalauncher_linux.cgi.

Configuring iDRAC Console On The Web GUI Server For Systems Running Linux 

To configure the Launch iDRAC tool on systems running Linux:

1. Log in to the web GUI running on a system running Linux.

2. Click Administration → Event Management Tools → Tool Creation. 

3. Double-click LaunchDelliDRACConsole.

4. Modify the name of the CGI Script in the URL section to idraclauncher_linux.cgi.
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Configuring Dell Chassis Management Controller Console On The Web GUI Server For 
Systems Running Linux 

To configure the Launch ChassisManagement Controller tool on systems running Linux :

1. Log in to the Web GUI running on a system running Linux.
2. Click Administration → Event Management Tools → Tool Creation. 
3. Double-click LaunchDellChassisManagementControllerConsole.
4. Modify the name of the CGI Script in the URL section to cmclauncher_linux.cgi.
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4
Upgrading Dell OpenManage Connection For 
Netcool/OMNIbus
To upgrade the Dell OpenManage Connection:

1. Uninstall the existing connection. For more information, see the Dell OpenManage Connection Installation Guide of 
the version installed at dell.com/support/manuals.

2. Install the latest version using the installation procedure described in Installing Dell OpenManage Connection For 
Netcool/OMNIbus.
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5
Uninstalling Dell OpenManage Connection For 
Netcool/OMNIbus
To uninstall Dell OpenManage Connection for Netcool/OMNIbus you must uninstall or remove the component-specific 
files.

Uninstalling Probe Integration
To uninstall the Probe integration:

1. Navigate to the%NC_RULES_HOME%/include-snmptrap folder on the system where you have installed the Probe 
component.

NOTE: On systems running Linux, use the $NC_RULES_HOME/include-snmptrap folder.

2. Perform the following steps:
Server Probe Integration

a. Comment or remove the following commands in %NC_RULES_HOME%/include-snmptrap/dell/
dell.master.include.rules

* include "$NC_RULES_HOME/include-snmptrap/dell/dell-MIB-
Dell-10892.include.snmptrap.rules"

* include "$NC_RULES_HOME/include-snmptrap/dell/dell-
StorageManagement-MIB.include.snmptrap.rules"

b. Comment or remove the following commands in %NC_RULES_HOME%/include-snmptrap/dell/
dell.master.include.lookup

* include "$NC_RULES_HOME/include-snmptrap/dell/dell-MIB-
Dell-10892.include.snmptrap.lookup"

* include "$NC_RULES_HOME/include-snmptrap/dell/dell-
StorageManagement-MIB.include.snmptrap.lookup"

c. Delete the following files from the %NC_RULES_HOME%/include-snmptrap/dell/ folder

* dell-MIB-Dell-10892.include.snmptrap.rules
* dell-StorageManagement-MIB.include.snmptrap.rules
* dell-MIB-Dell-10892.include.snmptrap.lookup
* dell-StorageManagement-MIB.include.snmptrap.lookup
* dellserver_int_mttrapdprobe.ver

EqualLogic Probe Integration

a. Comment or remove the following commands in %NC_RULES_HOME%/include-snmptrap/dell/
dell.master.include.rules

* include "$NC_RULES_HOME/include-snmptrap/dell/equalLogic-EQLMEMBER-
MIB.include.snmptrap.rules"
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* include "$NC_RULES_HOME/include-snmptrap/dell/equalLogic-EQLDISK-
MIB.include.snmptrap.rules"

* include "$NC_RULES_HOME/include-snmptrap/dell/equalLogic-SCSI-
MIB.include.snmptrap.rules"

* include "$NC_RULES_HOME/include-snmptrap/dell/equalLogic-ISCSI-
MIB.include.snmptrap.rules"

b. Comment or remove the following commands in %NC_RULES_HOME%/include-snmptrap/dell/
dell.master.include.lookup

* include "$NC_RULES_HOME/include-snmptrap/dell/equalLogic-EQLMEMBER-
MIB.include.snmptrap.lookup"

* include "$NC_RULES_HOME/include-snmptrap/dell/equalLogic-EQLDISK-
MIB.include.snmptrap.lookup"

* include "$NC_RULES_HOME/include-snmptrap/dell/equalLogic-SCSI-
MIB.include.snmptrap.lookup"

c. Delete the following files from the %NC_RULES_HOME%/include-snmptrap/dell/ folder

* equalLogic-EQLMEMBER-MIB.include.snmptrap.rules
* equalLogic-EQLDISK-MIB.include.snmptrap.rules
* equalLogic-SCSI-MIB.include.snmptrap.rules
* equalLogic-ISCSI-MIB.include.snmptrap.rules
* equalLogic-EQLMEMBER-MIB.include.snmptrap.lookup
* equalLogic-EQLDISK-MIB.include.snmptrap.lookup
* equalLogic-SCSI-MIB.include.snmptrap.lookup
* delleql_int_mttrapdprobe.ver

iDRAC Probe Integration

a. Comment or remove the following commands in %NC_RULES_HOME%/include-snmptrap/dell/
dell.master.include.rules
include "$NC_RULES_HOME/include-snmptrap/dell/dell-IDRAC-
MIB.include.snmptrap.rules"

b. Comment remove the following commands in %NC_RULES_HOME%/include-snmptrap/dell/
dell.master.include.lookup
include "$NC_RULES_HOME/include-snmptrap/dell/dell-IDRAC-
MIB.include.snmptrap.lookup"

c. Delete the following files from the %NC_RULES_HOME%/include-snmptrap/dell/ folder

* dell-IDRAC-MIB.include.snmptrap.rules
* dell-IDRAC-MIB.include.snmptrap.lookup
* dellserveridrac_int_mttrapdprobe.ver

CMC Probe Integration

a. Comment or remove the following commands in %NC_RULES_HOME%/include-snmptrap/dell/
dell.master.include.rules
include "$NC_RULES_HOME/include-snmptrap/dell/dell-RAC-
MIB.include.snmptrap.rules"

b. Comment or remove the following commands in %NC_RULES_HOME%/include-snmptrap/dell/
dell.master.include.lookup
include "$NC_RULES_HOME/include-snmptrap/dell/dell-RAC-
MIB.include.snmptrap.lookup"

c. Delete the following files from the %NC_RULES_HOME%/include-snmptrap/dell/folder

24



* dell-RAC-MIB.include.snmptrap.rules
* dell-RAC-MIB.include.snmptrap.lookup
* dellcmc_int_mttrapdprobe.ver

All Probe Integration

a. Remove or comment the following commands from NcKL master probe rules file.

* include "$NC_RULES_HOME/inlcude-snmptrap/dell/
dell.master.include.rules"

* include "$NC_RULES_HOME/include-snmptrap/dell/
dell.master.include.lookup"

b. Delete the folder dell under $NC_RULES_HOME/inlcude-snmptrap/

3. Restart the OMNIbus MTTrapd SNMP probe service (NCOMTTRAPDProbe) or process (nco_p_mttrapd).

Uninstalling ObjectServer Integration
To uninstall the ObjectServer integration:

1. Provide the required security credentials to access the OMNIbus ObjectServer and log in to the ObjectServer.

2. In the Configuration window, select Menu → Tools.

3. Perform the following steps:
Server ObjectServer Integration

a. Right-click the following tools and click Delete:

* Launch Dell Server Administrator Console

* Launch Dell Server Administrator Web Server Console

b. In the Configuration window, navigate to Automation Triggers and delete the following triggers:

* dell_omsa_clear

* dell_omsa_deduplicate_clear

c. In the Configuration window, navigate to Visual Conversions and expand Class. Right-click Dell Server (2080) 
and click Delete.

NOTE: This step must be performed only if the Dell Common Tools ObjectServer Integration does not 
exist.

d. In the %OMNIHOME% directory on the system where the ObjectServer is installed, remove the file 
dellserver_int_objectserver.ver.

EqualLogic ObjectServer Integration

a. Right-click Launch Dell EqualLogic Group Manager Console and click Delete.

b. In the Configuration window, navigate to Automation Triggers and delete the following triggers:

* dell_equallogic_clear

* dell_equallogic_deduplicate_clear

c. In the Configuration window, navigate to Visual Conversions and expand Class. Right-click Dell Equallogic 
(2085) and click Delete.

NOTE: This step must be performed only if the Dell Common Tools ObjectServer Integration does not 
exist.

d. In the %OMNIHOME% directory on the system where the ObjectServer is installed, remove the file 
delleql_int_objectserver.ver.
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iDRAC ObjectServer Integration

a. Right-click Launch iDRAC Console and click Delete.

b. In the Configuration window, navigate to Visual Conversions and expand Class. Right-click Dell iDRAC (2088) 
and click Delete.

NOTE: This step must be performed only if the Dell Common Tools ObjectServer Integration does not 
exist.

c. On the system where the ObjectServer is installed, in the %OMNIHOME% directory, remove the file 
dellserveridrac_int_objectserver.ver.

CMC ObjectServer Integration

a. Right click Launch Dell Chassis Management Controller Console and click Delete.

b. In the Configuration window navigate to Visual Conversions and expand Class. Right-click Dell CMC (2086) 
and click Delete.

NOTE: This step must be performed only if the Dell Common Tools ObjectServer Integration does not 
exist.

c. In the %OMNIHOME% directory on the system where the ObjectServer is installed, remove the file 
dellcmc_int_objectserver.ver.

Common Tools ObjectServer Integration

a. Right-click Launch Dell OpenManage Essentials Console and click Delete.

b. In the%OMNIHOME% directory on the system where the ObjectServer is installed, remove the file 
dellcommontools_int_objectserver.ver.

All ObjectServer Integration

a. Right-click the following tools and click Delete:

* Launch Dell Server Administrator Console

* Launch Dell Server Administrator Web Server Console

* Launch Dell EqualLogic Group Manager Console

* Launch iDRAC Console

* Launch Dell Chassis Management Controller Console

* Launch Dell OpenManage Essential Console

b. In the Configuration window, select Menu → Menus. Under the Alerts Menu, select Dell Tools. Right click 
Dell Tools and click Delete.

c. In the Configuration window navigate to Automation Triggers and delete the following triggers:

* dell_omsa_clear

* dell_omsa_deduplicate_clear

* dell_equallogic_clear

* dell_equallogic_deduplicate_clear

d. In the Configuration window navigate to Visual Conversions and expand the Class. Right-click the following 
and click Delete:

* Dell Server (2080)

* Dell Equallogic (2085)

* Dell iDRAC (2088)

* Dell CMC (2086)

e. In the %OMNIHOME% directory on the system where the ObjectServer is installed, remove the following files:
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* dellserver_int_objectserver.ver
* delleql_int_objectserver.ver
* dellserveridrac_int_objectserver.ver
* dellcmc_int_objectserver.ver
* dellcommontools_int_objectserver.ver

4. Open Event List and select File → Resync → All.
5. Restart the Web GUI.

Uninstalling Desktop Integration
To uninstall the desktop integration:

1. Navigate to the %OMNIHOME% directory on the system where you have installed the desktop integration 
components.

2. Perform the following steps:

– Server Desktop Integration — Remove the file dellserver_int_desktop.ver
– iDRAC Desktop Integration — Remove the file dellserveridrac_int_desktop.ver
– CMC Desktop Integration — Remove the file dellcmc_int_desktop.ver
– All Desktop Integration — Remove the following files:

* dellserver_int_desktop.ver
* dellserveridrac_int_desktop.ver
* dellcmc_int_desktop.ver 
* dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar
* dell_OMNIbus_Connection_SNMP_Helper_v_2_0.jar
* snmp4j-2.1.0.jar
* dell_config.properties

Uninstalling Web GUI Integration
To uninstall the web GUI integration:

1. Log on to the web GUI.
2. Perform the following steps:

Server Web GUI Integration

a. Remove the file dellserver_int_webgui.ver from the WEBGUI Install directory.

b. Navigate to Administration → Event Management Tools → Tool Creation. Select the following tools and click 
the delete icon.

1. Launch Dell Server Administrator Console

2. Launch Dell Server Administrator Web Server Console

c. Navigate to Administration → Event Management Tools  → CGI Registry. In the right pane, select 
omsalauncher_linux.cgi and omsalauncher_nt.cgi, and then click Unregister.

EqualLogic Web GUI Integration

a. Remove the file delleql_int_webgui.ver from the WEBGUI Install directory.

b. Navigate to Administration → Event Management Tools → Tool Creation. Select Launch EqualLogic Group 
Manager Console and click the delete icon.
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iDRAC Web GUI Integration

a. Remove the file dellserveridrac_int_webgui.ver from the WEBGUI Install directory.

b. Navigate to Administration → Event Management Tools → Tool Creation. Select Launch iDRAC Console tools 
and click the delete icon.

c. Navigate to Administration → Event Management Tools → CGI Registry. Select idraclauncher_linux.cgi and 
idraclauncher_nt.cgi, and then click Unregister.

CMC Web GUI Integration

a. Remove the file dellcmc_int_webgui.ver from the WEBGUI Install directory.

b. Navigate to Administration → Event Management Tools → Tool Creation. Select Launch Dell Chassis 
Management Controller Console tools and click the delete icon.

c. Navigate to Administration → Event Management Tools → CGI Registry. On the right pane, select 
cmclauncher_linux.cgi and cmclauncher_nt.cgi, and then click Unregister.

Common Tools Web GUI Integration

a. Remove the file dellcommontools_int_webgui.ver from the WEBGUI Install directory.

b. Navigate to Administration → Event Management Tools → Tool Creation. Select Launch Open Manage 
Essentials Console and click the delete icon.

All Web GUI Integration

a. Remove the following files from the WEBGUI Install directory.

* dellserver_int_webgui.ver

* delleql_int_webgui.ver

* dellserveridrac_int_webgui.ver

* dellcmc_int_webgui.ver

* dellcommontools_int_webgui.ver

* dell_OMNIbus_Connection_SNMP_Configurator_v_2_0.jar

* dell_OMNIbus_Connection_SNMP_Helper_v_2_0.jar

* snmp4j-2.1.0.jar

* dell_config.properties

b. Navigate to Administration → Event Management Tools → Tool Creation. Select following tools and click 
Delete.

* Launch Dell Server Administrator Console

* Launch Dell Server Administrator Web Server Console

* Launch EqualLogic Group Manager Console

* Launch iDRAC Console

* Launch Dell Chassis Management Controller Console

* Launch OpenManage Essentials Console

c. Navigate to Administration → Event Management Tools → Menu Configuration. Under Available menus, 
select DellTools and click Delete.

d. Navigate to Administration → Event Management Tools → CGI Registry. Select the following .cgi files, and 
then click Unregister.

* omsalauncher_linux.cgi

* omsalauncher_nt.cgi

* idraclauncher_linux.cgi 
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* idraclauncher_nt.cgi

* cmclauncher_linux.cgi 

* cmclauncher_nt.cgi
3. Restart the web GUI.
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6
Contacting Dell

NOTE: If you do not have an active Internet connection, you can find contact information on your purchase invoice, 
packing slip, bill, or Dell product catalog.

Dell provides several online and telephone-based support and service options. Availability varies by country and 
product, and some services may not be available in your area. To contact Dell for sales, technical support, or customer 
service issues:

1. Visit www.dell.com/support.
2. Select your support category.
3. Verify your country or region in the Choose a Country/Region drop-down menu at the top of page.
4. Select the appropriate service or support link based on your need.
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